using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\s+(\S+\.cpp)\s.*(?:\r?\n(?![01]\r?$).*)*\r?\n([10]+)\r?$";
string input = @"123 stringOfFilePathandName.cpp string 013
...not needed text...
...not needed text...
0
---------------------------------
56 stringOfFilePathandName2.cpp string 8756
...not needed text...
...not needed text...
1
---------------------------------";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}