# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)/$1$3$5/g;t' <<< "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >"