$re = '/(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)/';
$str = '<td class="sky" data-toggle="up" id="heaven" >';
$subst = "$1$3$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;