import re
regex = re.compile(r"(<\w+)(\s*[\w-]+=\"[^\"]+\")*(\s*data-toggle=\"[^\"]+\")(\s*[\w-]+=\"[^\"]+\")*(\s*>)")
test_str = "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >"
subst = "$1$3$5"
result = regex.sub(subst, test_str)
if result:
print(result)