const regex = /(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\w+)(\\s*[\\w-]+="[^"]+")*(\\s*data-toggle="[^"]+")(\\s*[\\w-]+="[^"]+")*(\\s*>)', 'g')
const str = `<td class="sky" data-toggle="up" id="heaven" >`;
const subst = `$1$3$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);