using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\w+)(\s*[\w-]+=""[^""]+"")*(\s*data-toggle=""[^""]+"")(\s*[\w-]+=""[^""]+"")*(\s*>)";
string substitution = @"$1$3$5";
string input = @"<td class=""sky"" data-toggle=""up"" id=""heaven"" >";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}