import Foundation
let pattern = #"(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<td class="sky" data-toggle="up" id="heaven" >"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)