using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\R)?\R{2,}";
string substitution = @"$1\n";
string input = @"line1
line2
line3
line4
line5
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}