import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\R)?\\R{2,}";
final String string = "line1\n\n"
+ "line2\n\n\n\n"
+ "line3\n\n\n\n\n"
+ "line4\n\n"
+ "line5\n";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}