const regex = /(\R)?\R{2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\R)?\\R{2,}', 'g')
const str = `line1
line2
line3
line4
line5
`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);