package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\R)?\R{2,}`)
var str = `line1
line2
line3
line4
line5
`
var substitution = "$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}