import Foundation
let pattern = #"(\R)?\R{2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
line1
line2
line3
line4
line5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)