re = /(\R)?\R{2,}/
str = 'line1
line2
line3
line4
line5
'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result