#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@\[[a-z0-9-]+\]\((\w+(?:-\w+)*)\)"
Local $sString = "@[a12-3asd-32](john) " & @CRLF & _
"@[b12-32d1-23](martha)" & @CRLF & _
"@[c12-12d1-13](john-user-1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")