re = /@\[[a-z0-9-]+\]\((\w+(?:-\w+)*)\)/m
str = '@[a12-3asd-32](john)
@[b12-32d1-23](martha)
@[c12-12d1-13](john-user-1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end