package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@\[[a-z0-9-]+\]\((\w+(?:-\w+)*)\)`)
var str = `@[a12-3asd-32](john)
@[b12-32d1-23](martha)
@[c12-12d1-13](john-user-1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}