using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\[[a-z0-9-]+\]\((\w+(?:-\w+)*)\)";
string input = @"@[a12-3asd-32](john)
@[b12-32d1-23](martha)
@[c12-12d1-13](john-user-1)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}