import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@\\[[a-z0-9-]+\\]\\((\\w+(?:-\\w+)*)\\)";
final String string = "@[a12-3asd-32](john) \n"
+ "@[b12-32d1-23](martha)\n"
+ "@[c12-12d1-13](john-user-1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}