use strict;
my $str = '@[a12-3asd-32](john)
@[b12-32d1-23](martha)
@[c12-12d1-13](john-user-1)';
my $regex = qr/@\[[a-z0-9-]+\]\((\w+(?:-\w+)*)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}