# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https:\\/\\/vk\.com.+\b(?<!\.png))$//gm;t' <<< "https://vk.com/images/iemoj/D83DDE0E.png
fdsfds https://vk.com/sadovodxasanov vcxfdsfds
fdsfdsfdf https://vk.com/id080845122210 fdsfdsffds
"