import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/vk\\.com.+\\b(?<!\\.png))$";
final String string = "https://vk.com/images/iemoj/D83DDE0E.png\n"
+ "fdsfds https://vk.com/sadovodxasanov vcxfdsfds\n"
+ "fdsfdsfdf https://vk.com/id080845122210 fdsfdsffds\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}