use strict;
my $str = 'https://vk.com/images/iemoj/D83DDE0E.png
fdsfds https://vk.com/sadovodxasanov vcxfdsfds
fdsfdsfdf https://vk.com/id080845122210 fdsfdsffds
';
my $regex = qr/(https:\/\/vk\.com.+\b(?<!\.png))$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";