using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https:\/\/vk\.com.+\b(?<!\.png))$";
string substitution = @"";
string input = @"https://vk.com/images/iemoj/D83DDE0E.png
fdsfds https://vk.com/sadovodxasanov vcxfdsfds
fdsfdsfdf https://vk.com/id080845122210 fdsfdsffds
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}