const regex = /(https:\/\/vk\.com.+\b(?<!\.png))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/vk\\.com.+\\b(?<!\\.png))$', 'gm')
const str = `https://vk.com/images/iemoj/D83DDE0E.png
fdsfds https://vk.com/sadovodxasanov vcxfdsfds
fdsfdsfdf https://vk.com/id080845122210 fdsfdsffds
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);