re = /(https:\/\/vk\.com.+\b(?<!\.png))$/m
str = 'https://vk.com/images/iemoj/D83DDE0E.png
fdsfds https://vk.com/sadovodxasanov vcxfdsfds
fdsfdsfdf https://vk.com/id080845122210 fdsfdsffds
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result