$re = '/(https:\/\/vk\.com.+\b(?<!\.png))$/m';
$str = 'https://vk.com/images/iemoj/D83DDE0E.png
fdsfds https://vk.com/sadovodxasanov vcxfdsfds
fdsfdsfdf https://vk.com/id080845122210 fdsfdsffds
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;