import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{3})(\\w+)?(\\w{3})";
final String string = "Hmm. We’re having trouble finding that site.\n\n"
+ "Check that Firefox has permission to access the web (you might be connected but behind a firewall)\n\n"
+ "vamos fazer de conta que criamos um projeto de multipla escolha\n\n"
+ "codigo-cliente-no-cadastro-unico\n"
+ "cxp-microintegration-teste-sistema-conta\n"
+ "testando-abreviação-simples-com-expressões-regulares\n\n"
+ "Your account, a is not authorized to view this page. Make sure the URL is correct and your account has access.";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}