use strict;
my $str = 'Hmm. We’re having trouble finding that site.
Check that Firefox has permission to access the web (you might be connected but behind a firewall)
vamos fazer de conta que criamos um projeto de multipla escolha
codigo-cliente-no-cadastro-unico
cxp-microintegration-teste-sistema-conta
testando-abreviação-simples-com-expressões-regulares
Your account, a is not authorized to view this page. Make sure the URL is correct and your account has access.';
my $regex = qr/(\w{3})(\w+)?(\w{3})/mp;
my $subst = '$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";