const regex = /(\w{3})(\w+)?(\w{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{3})(\\w+)?(\\w{3})', 'gm')
const str = `Hmm. We’re having trouble finding that site.
Check that Firefox has permission to access the web (you might be connected but behind a firewall)
vamos fazer de conta que criamos um projeto de multipla escolha
codigo-cliente-no-cadastro-unico
cxp-microintegration-teste-sistema-conta
testando-abreviação-simples-com-expressões-regulares
Your account, a is not authorized to view this page. Make sure the URL is correct and your account has access.`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);