# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!--sec:\s*([\s\S]*?)\s*#-->/{$1}/g;t' <<< "<!-- Normal Comment -->
<!--sec: Secret Comment #-->
<!-- Normal Comment 2 -->"