#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<!--sec:\s*([\s\S]*?)\s*#-->"
Local $sString = "<!-- Normal Comment -->" & @CRLF & _
"<!--sec: Secret Comment #-->" & @CRLF & _
"<!-- Normal Comment 2 -->"
Local $sSubst = "{$1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)