$re = '/<!--sec:\s*([\s\S]*?)\s*#-->/';
$str = '<!-- Normal Comment -->
<!--sec: Secret Comment #-->
<!-- Normal Comment 2 -->';
$subst = "{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;