use strict;
my $str = '<!-- Normal Comment -->
<!--sec: Secret Comment #-->
<!-- Normal Comment 2 -->';
my $regex = qr/<!--sec:\s*([\s\S]*?)\s*#-->/p;
my $subst = '{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";