using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--sec:\s*([\s\S]*?)\s*#-->";
string substitution = @"{$1}";
string input = @"<!-- Normal Comment -->
<!--sec: Secret Comment #-->
<!-- Normal Comment 2 -->";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}