re = /<!--sec:\s*([\s\S]*?)\s*#-->/
str = '<!-- Normal Comment -->
<!--sec: Secret Comment #-->
<!-- Normal Comment 2 -->'
subst = '{$1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result