const regex = /<!--sec:\s*([\s\S]*?)\s*#-->/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--sec:\\s*([\\s\\S]*?)\\s*#-->', 'g')
const str = `<!-- Normal Comment -->
<!--sec: Secret Comment #-->
<!-- Normal Comment 2 -->`;
const subst = `{$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);