#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^((\*\/)?([1-5]?[0-9])((\,|\-|\/)\d+)*|\*)\s((\*\/)?((2[0-3]|1[0-9]|[0-9]))((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|[12][0-9]|3[01])((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|1[0-2])((\,|\-|\/)\d+)*|\*)\s((\*\/)?[0-6]((\,|\-|\/)\d+)*|\*)$)|@(annually|yearly|monthly|weekly|daily|hourly|reboot)"
Local $sString = "# should pass:" & @CRLF & _
"12 1 1 * 1" & @CRLF & _
"0 1 1 * 1,2" & @CRLF & _
"0 1 1 * 1,2,3" & @CRLF & _
"0 1 * * 1/4" & @CRLF & _
"0 */2 * * *" & @CRLF & _
"0 9-17 * * *" & @CRLF & _
"0 * * * 2/4" & @CRLF & _
"* * * * *" & @CRLF & _
"* * * * *" & @CRLF & _
"0 4 * * 1-5" & @CRLF & _
"*/5 * * * *" & @CRLF & _
"37 1-23/2 * * *" & @CRLF & _
"0 0,12 1 */2 *" & @CRLF & _
"0 0 1,15 * 3" & @CRLF & _
"@weekly" & @CRLF & _
"0 5,17 * * *" & @CRLF & _
"5 0 * 8 *" & @CRLF & _
"0 22 * * 1-5" & @CRLF & _
"23 0-20/2 * * *" & @CRLF & _
"0 0,12 1 */2 *" & @CRLF & _
"" & @CRLF & _
"# should not pass:" & @CRLF & _
"0 * * 0 1-4" & @CRLF & _
"0 0 0 12 * " & @CRLF & _
"*-* * * * *" & @CRLF & _
"* * *-1 * *" & @CRLF & _
"*1 * 1 * *" & @CRLF & _
"1* * 1 * *"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")