package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^((\*\/)?([1-5]?[0-9])((\,|\-|\/)\d+)*|\*)\s((\*\/)?((2[0-3]|1[0-9]|[0-9]))((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|[12][0-9]|3[01])((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|1[0-2])((\,|\-|\/)\d+)*|\*)\s((\*\/)?[0-6]((\,|\-|\/)\d+)*|\*)$)|@(annually|yearly|monthly|weekly|daily|hourly|reboot)`)
var str = `# should pass:
12 1 1 * 1
0 1 1 * 1,2
0 1 1 * 1,2,3
0 1 * * 1/4
0 */2 * * *
0 9-17 * * *
0 * * * 2/4
* * * * *
* * * * *
0 4 * * 1-5
*/5 * * * *
37 1-23/2 * * *
0 0,12 1 */2 *
0 0 1,15 * 3
@weekly
0 5,17 * * *
5 0 * 8 *
0 22 * * 1-5
23 0-20/2 * * *
0 0,12 1 */2 *
# should not pass:
0 * * 0 1-4
0 0 0 12 *
*-* * * * *
* * *-1 * *
*1 * 1 * *
1* * 1 * *`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}