import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^((\\*\\/)?([1-5]?[0-9])((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?((2[0-3]|1[0-9]|[0-9]))((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?([1-9]|[12][0-9]|3[01])((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?([1-9]|1[0-2])((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?[0-6]((\\,|\\-|\\/)\\d+)*|\\*)$)|@(annually|yearly|monthly|weekly|daily|hourly|reboot)";
final String string = "# should pass:\n"
+ "12 1 1 * 1\n"
+ "0 1 1 * 1,2\n"
+ "0 1 1 * 1,2,3\n"
+ "0 1 * * 1/4\n"
+ "0 */2 * * *\n"
+ "0 9-17 * * *\n"
+ "0 * * * 2/4\n"
+ "* * * * *\n"
+ "* * * * *\n"
+ "0 4 * * 1-5\n"
+ "*/5 * * * *\n"
+ "37 1-23/2 * * *\n"
+ "0 0,12 1 */2 *\n"
+ "0 0 1,15 * 3\n"
+ "@weekly\n"
+ "0 5,17 * * *\n"
+ "5 0 * 8 *\n"
+ "0 22 * * 1-5\n"
+ "23 0-20/2 * * *\n"
+ "0 0,12 1 */2 *\n\n"
+ "# should not pass:\n"
+ "0 * * 0 1-4\n"
+ "0 0 0 12 * \n"
+ "*-* * * * *\n"
+ "* * *-1 * *\n"
+ "*1 * 1 * *\n"
+ "1* * 1 * *";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}