# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^((\*\/)?([1-5]?[0-9])((\,|\-|\/)\d+)*|\*)\s((\*\/)?((2[0-3]|1[0-9]|[0-9]))((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|[12][0-9]|3[01])((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|1[0-2])((\,|\-|\/)\d+)*|\*)\s((\*\/)?[0-6]((\,|\-|\/)\d+)*|\*)$)|@(annually|yearly|monthly|weekly|daily|hourly|reboot)"
test_str = ("# should pass:\n"
"12 1 1 * 1\n"
"0 1 1 * 1,2\n"
"0 1 1 * 1,2,3\n"
"0 1 * * 1/4\n"
"0 */2 * * *\n"
"0 9-17 * * *\n"
"0 * * * 2/4\n"
"* * * * *\n"
"* * * * *\n"
"0 4 * * 1-5\n"
"*/5 * * * *\n"
"37 1-23/2 * * *\n"
"0 0,12 1 */2 *\n"
"0 0 1,15 * 3\n"
"@weekly\n"
"0 5,17 * * *\n"
"5 0 * 8 *\n"
"0 22 * * 1-5\n"
"23 0-20/2 * * *\n"
"0 0,12 1 */2 *\n\n"
"# should not pass:\n"
"0 * * 0 1-4\n"
"0 0 0 12 * \n"
"*-* * * * *\n"
"* * *-1 * *\n"
"*1 * 1 * *\n"
"1* * 1 * *")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.