use strict;
my $str = '# should pass:
12 1 1 * 1
0 1 1 * 1,2
0 1 1 * 1,2,3
0 1 * * 1/4
0 */2 * * *
0 9-17 * * *
0 * * * 2/4
* * * * *
* * * * *
0 4 * * 1-5
*/5 * * * *
37 1-23/2 * * *
0 0,12 1 */2 *
0 0 1,15 * 3
@weekly
0 5,17 * * *
5 0 * 8 *
0 22 * * 1-5
23 0-20/2 * * *
0 0,12 1 */2 *
# should not pass:
0 * * 0 1-4
0 0 0 12 *
*-* * * * *
* * *-1 * *
*1 * 1 * *
1* * 1 * *';
my $regex = qr`(^((\*\/)?([1-5]?[0-9])((\,|\-|\/)\d+)*|\*)\s((\*\/)?((2[0-3]|1[0-9]|[0-9]))((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|[12][0-9]|3[01])((\,|\-|\/)\d+)*|\*)\s((\*\/)?([1-9]|1[0-2])((\,|\-|\/)\d+)*|\*)\s((\*\/)?[0-6]((\,|\-|\/)\d+)*|\*)$)|@(annually|yearly|monthly|weekly|daily|hourly|reboot)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}