# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|^a\.).*?\Kain't/is not/gmi;t' <<< "For instance, if in the text below I wanted to replace \"ain't\" with \"is not\" for lines beginning \"a.\" but not \"b.\":
a. This ain't a worm.
b. No, it ain't.
a. Ain't a snake, either.
b. No, ain't one of them.
a. ain't multiple ain't and more ain't
"