import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)|^a\\.).*?\\Kain't";
final String string = "For instance, if in the text below I wanted to replace \"ain't\" with \"is not\" for lines beginning \"a.\" but not \"b.\":\n"
+ "a. This ain't a worm.\n"
+ "b. No, it ain't.\n"
+ "a. Ain't a snake, either.\n"
+ "b. No, ain't one of them. \n"
+ "a. ain't multiple ain't and more ain't\n";
final String subst = "is not";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}