$re = '/(?:\G(?!^)|^a\.).*?\Kain\'t/mi';
$str = 'For instance, if in the text below I wanted to replace "ain\'t" with "is not" for lines beginning "a." but not "b.":
a. This ain\'t a worm.
b. No, it ain\'t.
a. Ain\'t a snake, either.
b. No, ain\'t one of them.
a. ain\'t multiple ain\'t and more ain\'t
';
$subst = "is not";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;