import re
regex = re.compile(r"(?:\G(?!^)|^a\.).*?\Kain't", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("For instance, if in the text below I wanted to replace \"ain't\" with \"is not\" for lines beginning \"a.\" but not \"b.\":\n"
"a. This ain't a worm.\n"
"b. No, it ain't.\n"
"a. Ain't a snake, either.\n"
"b. No, ain't one of them. \n"
"a. ain't multiple ain't and more ain't\n")
subst = "is not"
result = regex.sub(subst, test_str)
if result:
print(result)