using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|^a\.).*?\Kain't";
string substitution = @"is not";
string input = @"For instance, if in the text below I wanted to replace ""ain't"" with ""is not"" for lines beginning ""a."" but not ""b."":
a. This ain't a worm.
b. No, it ain't.
a. Ain't a snake, either.
b. No, ain't one of them.
a. ain't multiple ain't and more ain't
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}