# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^0-9A-Za-z\n]|[a-zA-Z]+$//gm;t' <<< "MA0244891-D
--> MA0244891
MA0244891
--> MA0244891
MA0244891D
--> MA0244891
0244891D
--> 0244891"