package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^0-9A-Za-z\n]|[a-zA-Z]+$`)
var str = `MA0244891-D
--> MA0244891
MA0244891
--> MA0244891
MA0244891D
--> MA0244891
0244891D
--> 0244891`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}