$re = '/[^0-9A-Za-z\n]|[a-zA-Z]+$/m';
$str = 'MA0244891-D
--> MA0244891
MA0244891
--> MA0244891
MA0244891D
--> MA0244891
0244891D
--> 0244891';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;