use strict;
my $str = 'MA0244891-D
--> MA0244891
MA0244891
--> MA0244891
MA0244891D
--> MA0244891
0244891D
--> 0244891';
my $regex = qr/[^0-9A-Za-z\n]|[a-zA-Z]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";